
                      
FastCourse Access 2007: Level 2 
Quick References

Quick Reference tables provide generic instructions for key tasks. This document contains 
various Quick Reference tables for tasks you have learned in this course. You may want to print 
this document or save it to your Desktop to use as a reference.

DESIGNING DATABASES 
Step Task

1 Identify the purpose of the database.

2 Locate and organize detailed information about what the database should contain, 
such as employee data, customer information, and inventory details—many of these will 
become fields.

3 Separate the details into related groups—these will make up your tables.

4 Identify additional breakdowns in information details, such as breaking Name into first 
name and last name. Also, separate information such as totals calculated using values in 
other fields. You won’t need these in the tables.

5 Specify a primary key for each group of data. 

6 Relate tables to each other by identifying how data in one table can be connected to 
data in other tables, and then add the necessary fields to tables or create new tables to 
help connect the data.

7 Create the database in Access and test the design. By creating the tables and entering 
sample data into each table, you can test the design to ensure that it provides the 
expected results. Refine as needed.

8 Apply normalization rules and make any necessary adjustments.

FORMATTING SYMBOLS FOR TEXT AND MEMO FIELDS 
Format 
Symbol Description

@ Requires data entry of a character or space

> Forces all characters in the field to uppercase

< Forces all characters in the field to lowercase

& Text is not required

VIEWING OBJECT DEPENDENCIES 
Task Procedure

View Object 
Dependencies

■ Select the object for which you want to view dependencies.

■ Choose Database Tools →Show/Hide→Object Dependencies . 
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CREATING, SAVING, AND RUNNING SELECT QUERIES 
Task Procedure

Create a Query 
in Query 
Design 

■ Choose Create→Other→Query Design  on the Ribbon.

■ Add appropriate tables to the query, and then click Close.

■ Add fields and appropriate criteria to the query grid.

Save a Query ■ Create the query and click Save .

■ Type a name for the query and click OK.

Run a Query ■ Double-click a query name in the Navigation Pane.

■ or

■ Create the query and display the query in Design View.

■ Choose Design→Results→Run  on the Ribbon.

DEFINING WILDCARD SYMBOLS
Symbol Description of Use

An asterisk (*) Substitutes for a group of characters that appears at the position of the asterisk 

Example: If you type R* in the last name column of a query grid, Access will locate all 
names beginning with R regardless of how many characters make up the name—
Rogers, Rich, and Rovarino would all appear in the results datasheet.

A question 
mark (?)

Substitutes for a single character that might appear at the position of the 
question mark 

Example: If you type m?s in the criteria row for a column, Access will locate records 
containing values such as mrs, ms, mbs, and so forth.

USING AND AND OR CRITERIA
Criterion Type Description

AND Use to select records that meet all criteria set in all query grid fields. For example, 
you might set AND criteria to locate customers from a specific city within a state by 
typing the city name in the City field on the query grid and the state in the State 
field on the grid.

OR Use to select records meeting one condition or another condition whether the 
criteria are set for the same field or different fields. For example, you could set OR 
criteria to locate customers from two different states. By setting OR criteria, Access 
displays all records containing one state or the other state in the State field.
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SETTING A QUERY SORT ORDER
Task Procedure

Set a Sort Order ■ Display the query in Query Design View.

■ Click the Sort row of the query grid for the field on which you want to sort.

■ Select the appropriate sort order for the field.

Set Sort Orders for 
Multiple Fields

■ Display the query in Query Design View and arrange the fields left to right 
in the order in which you want Access to sort.

■ Click the Sort row of the query grid for the field on which you want to sort.

■ Select the appropriate sort order for the field.

■ Repeat these steps for each additional field that you want to sort.

Limit the Number of 
Records Returned

■ Display the query in Query Design View.

■ Choose Design→Query Setup→Return menu  and select the number of 
records you want to view.

IDENTIFYING THE ORDER OF MATHEMATICAL CALCULATIONS

Item Calculation Description

A Parentheses Calculations enclosed in parentheses are performed first.

B Exponentials Calculations “raised to the power of”, such as squared or cubed, 
are performed next. Exponents appear as raised numbers, such as 
in x2.

C Multiplication/Division Multiplication and division are equal in calculation order and are 
calculated left to right, after calculations on parentheses 
and exponentials.

D Addition/Subtraction Addition and subtraction are equal in calculation order and are 
calculated last, left to right across a formula.

USING CALCULATED DATES IN EXPRESSIONS
Sample Field Returns

CurrentDate: =Date() 
or
CurrentDate: Now()

Displays the current date in the mm-dd-yyyy format, 
where mm is the month, dd is the day, and yyyy is the 
year.

OrderProcessing: 
DateDiff("d", [OrderDate], [ShippedDate])

Displays the number of days (d) between the value in 
the OrderDate field and the ShippedDate field.

(Now()-[DOB])/365 Subtracts the value in the DOB (date of birth) field from 
the current date and divides the difference by 365 to 
display the calculated value in years.

▼

A B

C

D
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CREATING CROSSTAB, UNMATCHED, AND DUPLICATES QUERIES 
USING WIZARDS
Task Procedure

Create Crosstab 
Query

■ Choose Create→Other→Query Wizard  on the Ribbon.

■ Double-click Crosstab Query Wizard.

■ Follow screens to select objects and fields required to build the query.

Create Find 
Duplicates Query 

■ Choose Create→Other→Query Wizard  on the Ribbon.

■ Double-click Find Duplicates Query Wizard.

■ Follow screens to select objects and fields required to build the query.

Create Find 
Unmatched Query

■ Choose Create→Other→Query Wizard  on the Ribbon.

■ Double-click Find Unmatched Query Wizard.

■ Follow screens to select objects and fields required to build the query.

USING FORM ELEMENTS 
Element Description

Sections The major parts of the form, such as the Form Header, the Form Footer, the 
Detail, the Page Header, and the Page Footer. Section bars divide 
form sections.

Controls Items on a form that display data, perform actions, and decorate the form. 
Access uses three main types of data controls on forms—bound controls, 
unbound controls, and calculated controls. Each data control consists of 
two parts—control label and control text box—that are tied to a field in a 
database table. 

Bound control A control that ties, or binds, data displayed on a form to a field in a database 
table so that the field value appears on the form. Bound controls normally 
appear in the Detail section of a form.

Unbound control An item on a form that is independent of data and fields in a database table. 
Unbound controls can be lines, rectangles, pictures, and so forth. Unbound 
controls can appear in any form section.

Calculated control A control that is tied to an expression or calculated field constructed in a query. 
Calculated controls normally appear in the Detail or Form Footer section of the 
form. 

Control label The part of a control that contains text to identify the data displayed on the 
form. Normally, the control label text is the field name or caption set for the 
field. For example, Employee Number is a label that identifies the Employee# 
field.

Control text box The part of a control that displays data from a field in an Access table. For 
example, ToliP01 is the data contained in the Employee# field.

Form Header/Footer The sections of a form that contain text, pictures, and other items that are 
repeated at the top (header) or bottom (footer) of each form. 

Detail section The main section of the form, which normally displays data from database 
tables that varies from record to record.

Page Header/Footer The sections of a form that contain text and other items that are repeated at 
the top (header) or bottom (footer) of every page of an individual record 
displayed in the form. 



                                 
CREATING FORMS 
Task Procedure

Create a Simple Form ■ Select the table for which you want to create a form.

■ Choose Create→Forms→Form  on the Ribbon.

Create a Form in 
Design View

■ Select the table for which you want to create a form.

■ Choose Create→Forms→Form Design  on the Ribbon.

Create a Split Form ■ Select the table for which you want to create the form.

■ Choose Create→Forms→Split Form  on the Ribbon.

Create a Form Using 
a Wizard

■ Select the table for which you want to create the form.

■ Choose Create→Forms→More Forms→Form Wizard  on 
the Ribbon.

Create a Multiple 
Item Form

■ Choose Create→Forms→Multiple Items  on the Ribbon.

DELETING CONTROLS AND LABELS 
Task Procedure

Delete an entire 
control

■ Select the text box part of the control.

■ Press [Delete].

Delete a label ■ Select the label part of the control.

■ Press [Delete].

SELECTING MULTIPLE CONTROLS 
Task Procedure

Select Controls 
Individually

■ Click the first control.

■ Press and hold [Shift] and click each additional control.

Select Controls in a 
Horizontal or 
Vertical Line

■ Point to the vertical ruler on the left side of the form until the 
mouse pointer appears as a right-pointing arrow and click to 
select all controls horizontally.

■ Point to the horizontal ruler at the top of the form until the 
mouse pointer appears as a down-pointing arrow and click to 
select all controls vertically.

Select Controls in a 
General Area of 
the Form

■ Point to a position slightly outside the area of the top left 
control and then drag the mouse pointer to a position slightly 
outside the area of the bottom right control.
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ALIGNING SELECTED CONTROLS 
Task Procedure

Align Controls 
Using 
the Ribbon

■ Select multiple controls.

■ Choose Arrange→Control Alignment and click the alignment button that 
represents the alignment you want to apply—Left, Right, Top, Bottom, To Grid.

Align Controls 
Using the 
Shortcut 
Menu

■ Select multiple controls.

■ Right-click one of the selected controls and choose the Align menu.

■ Choose the alignment you want to apply—Left, Right, Top, Bottom, To Grid.

APPLYING AN AUTOFORMAT TO A FORM 
Task Procedure

Apply an 
AutoFormat 
to a Form

■ Display the form to which you want to apply the AutoFormat in Design View.

■ Choose Arrange → AutoFormat → AutoFormat  on the Ribbon.

■ Choose the AutoFormat design to apply. 

PRINTING RECORD FORMS 
Task Procedure

Print All 
Records

■ Choose Office→Print Menu→Quick Print.

Print Specific 
Records

■ Choose Office→Print menu  Print Preview.

■ Choose Print Preview→Print→Print  on the Ribbon.

■ Set the options you want to apply and click OK.

▼
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IDENTIFYING REPORT DESIGN ELEMENTS
Report Element Description

Sections The major parts of the report, such as the Report Header, the Report Footer, 
the Detail, the Page Header, and the Page Footer. Section bars divide 
report sections.

Controls Items on a form or report that display data, perform actions, and decorate 
the object. Access uses three main types of controls on reports—bound 
controls, unbound controls, and calculated controls. Each control consists of 
two parts—control label and control text box—that are tied to a field in a 
database table.

Bound control A control that ties, or binds, data displayed on a report to a field in a 
database table so that the field value appears on the report. Bound controls 
normally appear in the Detail section of a report.

Unbound control An item on a report that is independent of data and fields in a database 
table. Unbound controls can be lines, rectangles, pictures, and so forth. 
Unbound controls can appear in any report section.

Calculated control A control that is tied to an expression created for the report or to a 
calculated field constructed in a query. Calculated controls normally appear 
in the Detail or Report Footer section of the report. 

Control label The part of a control that contains text to identify the data displayed on the 
report. Normally, the control label text is the field name or caption set for 
the field. For example, Employee Number is a label that identifies the 
Employee# field.

Control text box The part of a control that displays data from a field in an Access table. For 
example, ToliP01 is the data contained in the Employee# field.

Report Header/Footer The sections of a report that contain text, pictures, and other items that are 
repeated at the top (header) or bottom (footer) of the report. 

Detail section The main section of a report, which normally displays data from database 
tables that varies from record to record.

Page Header/Footer The sections of a report that contain text and other items that are repeated 
at the top (header) or bottom (footer) of every page of the report.

Group Header/Footer The sections that identify a field on which data in the report is grouped 
(Group Header) and enables you to report summary data for the group 
(Group Footer). The name of the grouped field appears in the Group 
Header and Footer bars.
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USING REPORT VIEWS 
View Description Use this view to . . .

Report Displays when you open a report. Report 
View does not permit modification of 
formatting or data. Report View presents 
the report as it will print. 

■ Preview a report layout before printing. 

■ View summarized data.

Layout Displays a “run” of a report layout with 
sample data displayed so that you can size 
and position controls appropriately. You can 
modify formatting in this view as well as use 
many of the same design tools that are 
available in Design View. 

■ Preview a report with data.

■ Size and position controls and ensure 
that all data contained in a field displays 
properly on a report.

■ Add a limited number of controls to 
a report.

Design Displays the design palette containing 
sections and section bars, controls, labels, 
design elements, and other report features. 
In addition, tools for adding many 
additional controls are available in 
Design View.

■ Format and design a report.

■ Add summary data and controls.

■ Add design elements.

SWITCHING AMONG REPORT VIEWS
Task Procedure

Display Report 
View

■ Open a report.

■ Choose Format→Views→View menu  and choose Report View.
or
Choose Home→Views→View menu  and choose Report View. 

Display Design 
View

■ Right-click a report name in the Navigation Pane and choose Design View.

or

■ Open a report and choose Format→Views→View menu  and choose 
Design View.

or

■ Open a report and choose Home→Views→View menu  and choose 
Design View.

Display Layout 
View

■ Right-click a report name in the Navigation Pane and choose Layout View.

or

■ Open a report and choose Format→Views→View menu  and choose 
Layout View.

or

■ Open a report and choose Home→Views→View menu  and choose 
Layout View.

▼

▼

▼

▼

▼

▼



ADDING CONTROLS TO A REPORT
Task Procedure

Drag Controls ■ Display the report in Layout or Design View.

■ Choose Format→Controls→Add Existing Fields  to open the Field List.

■ Expand the table containing the field you want to add.

■ Drag the field onto the report and position it where you want it.

Add Controls from 
a Ribbon

■ Display the report in Design View.

■ Choose Design→Controls and click the control type button you want to add 
to the report.

■ Click or drag a control in the position and size you want on the report.

ADDING SORT AND GROUP LEVELS
Task Procedure

Display the Panel 
Using the Ribbon in 
Design View

■ Display the report is Design View.

■ Choose Design→Grouping & Totals→Group & Sort  on the Ribbon.

Display the Panel 
Using the Ribbon in 
Layout View

■ Display the report in Layout View.

■ Choose Format→Grouping & Totals→Group & Sort  on the 
Ribbon.

Add Group Level ■ Right-click the field on which you want to group data records.

■ Choose Group On.

Add Sort Order ■ Right-click the field on which you want to sort data or groups.

■ Choose Sort A to Z or Smallest to Largest  
or 
Choose Sort Z to A or Largest to Smallest .

ADDING DATE AND TIME FIELDS TO A REPORT
Task Procedure

Add Date Field to 
a Report

■ Choose Design→Controls→Date & Time  on the Ribbon.

■ Check the Include Date check box, select the format option, and click OK.

Add Time Field to 
a Report

■ Choose Design→Controls→Date & Time  on the Ribbon.

■ Check the Include Time check box, select the format option and click OK.
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ADDING A LOGO TO A REPORT OR FORM
Task Procedure

Add a Logo to a 
Report or Form

■ Display the form or report in Design View.

■ Choose Design→Controls→Logo  on the Ribbon.

APPLYING AN AUTOFORMAT TO FORMS AND REPORTS
Task Procedure

Apply an 
AutoFormat

■ Prepare the report or form to which you want to apply the AutoFormat.

■ Display the report or form in Design View. 

■ Choose Arrange→AutoFormat→AutoFormat  on the Ribbon.

■ Select the AutoFormat to apply.

USING THE EXPRESSION BUILDER
Task Procedure

Create a Calculated 
Control Using the 
Expression Builder

■ Display the form or report in Design View.

■ Choose Design→Controls→Text Box  on the Ribbon. 

■ Click or draw the control on the form or report palette where you want it 
to appear.

■ Press [F4] to display the Property Sheet and click the Data tab.

■ Click the Control Source property and then click the Build  button.

■ Add fields, operators, and other elements to the expression and then 
click OK.

USING GROUP, SORT, AND TOTAL FEATURES
Task Procedure

Display the Group 
Footer section

■ Display the report in Design View.

■ Choose Design→Grouping & Totals→Group & Sort  on the Ribbon.

■ Click More on the Group bar for the group for which you want to display 
a footer.

■ Click the Without a Footer Section list button and choose With a 
Footer Section.

Set Aggregate 
Function Totals from 
the Group Bar

■ Display the report in Design View.

■ Choose Design→Grouping & Totals→Group & Sort  on the Ribbon.

■ Click More on the Group bar for the group for which you want to display 
aggregate functions.

■ Click the with no totals list button and set the field, type, and position of 
the function you want to set.

Set Aggregate 
Function Totals from 
the Ribbon

■ Display the report in Design View and click the field control in the Detail 
section for which you want to set a function.

■ Choose Design→Grouping & Totals→Totals  on the Ribbon.

■ Choose the function you want to apply to the field.
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CREATING LABELS
Task Procedure

Launch the Label 
Wizard

■ Select the table containing the data you want to use for the labels.

■ Choose Create→Reports→Labels .

Work Through 
Wizard Screens

■ Select the label type, format, and unit of measure you want to use for the 
labels and click Next.

■ Set the font, size, and color, and then click Next.

Add Fields to a Label ■ Double-click the field names in the Available Fields list in the order you 
want them to appear on the label.

■ Add spacing, punctuation, and hard returns as needed to position the 
fields properly.

■ Click Next.

■ Select the field on which you want to sort the labels and click Next.

■ Type a label report name and click Finish.

PRINTING RECORD FORMS
Task Procedure

Print Specific Pages ■ Choose Office→Print menu  Print Preview.

■ Choose Print Preview→Print→Print .

■ Set the options you want to apply and click OK.

▼
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